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Your Best STL Learning Tools
Welcome to your Best STL training course.

As part of your training, we provide you with the following tools and resources to support and enhance your learning experience.

Thank you for choosing Best STL.
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Module One: Working with Large Worksheets
In this module we will be exploring the  different ways of managing a larger worksheet using tools such as,  zoom, freeze panes, outlining, views and many more.
An Overview of Excel’s Views

The View tab controls how a worksheet appears on screen. Changing the worksheet view does not impact the way your worksheet prints, only the way you see it on your monitor. The different views are:

· Normal is the view used for entering data.

· Page Layout view displays what the data will look like when printed. You can use Page Layout view to add headers and footers to your worksheets.

· Page Break Preview allows you to adjust where the page breaks occur. You can drag the blue border to a new location for columns or rows to adjust the page breaks.

· Full screen view displays the worksheet using the full screen. It does not display the Ribbon or Status Bar. Press the ESC key to leave full screen view.

Shown here is the View tab on the Ribbon.
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Switching Views

Use the following procedure to view the Page Layout View.

1. Select the View tab. Select the Page Layout tool.
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There are three areas for the header and the footer. Investigate entering header content in the left, middle, and right of the header and/or footer.

Use the following procedure to view the Page Break Preview.

1. Select the View tab. Select the Page Break Preview tool.
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Investigate what happens if they move the blue borders. Switch to Page Layout View to see the difference.

Creating Custom Views

A custom view is a set of settings that you can save for the active workbook and reapply at different times. This helps if you want to view the same data in different ways. Instead of creating different copies of the workbook to see the different views, or redoing a number of settings each time you want to change them, you can create multiple custom views for the workbook. The custom view only applies to the current workbook.

Custom views can include a number of different settings, including column widths and page layout items such as headers and footers. Custom views can also include many features that will be covered later in this course.

Use the following procedure to create a custom view.

1. Select Custom Views from the View tab on the Ribbon.
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Excel opens the Custom Views dialog box.
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2. Select Add to open the Add View dialog box.
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3. Enter the Name of your view. 

4. Check the Print Settings box to include the print settings in your custom view.

5. Check the Hidden rows, columns and filter settings to include those in your custom view.

6. Select OK.

Use the following procedure to apply a custom view.

1. Select Custom Views from the View tab on the Ribbon.
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2. Highlight the View you want to apply and select Show.
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Using Zoom

Excel allows you to zoom in or out so that you can make the type appear larger, or see more of your worksheet to check the layout. The View tab includes the zoom tools.
Use the following procedure to zoom to a selection.

1. Highlight the area you want to view larger.

2. Select the Zoom to Selection tool from the View tab on the Ribbon.
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3. Select 100% from the View tab on the Ribbon to return to the default zoom.

Switching Between Open Files


Use the following procedure to switch from one worksheet to another.

1. Select the Switch Windows tool from the View tab on the Ribbon. Select the worksheet you want to view from the list.
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Using Freeze Panes

It is sometimes convenient to be able to keep an eye on one part of a spreadsheet while simultaneously

viewing other parts of the same spreadsheet (for example, keeping cells with headings in place while

scrolling through the data). If you want to see multiple parts of your worksheet at the same time, you can segment your Excel 2010 screen into more than one viewing area by using Excel’s Freeze feature.

To use Freeze Panes, open a workbook window, and click the Freeze Panes button on the View tab.

Clicking this button will display a menu of freeze options that you can choose from.

[image: image15.emf]
To freeze panes (columns and rows):

· Select the first cell of data

· Go to the View tab

· In the Window group, select Freeze Panes
[image: image16.emf]
To freeze panes (top row only):

· Go to the View tab

· In the Window group, select Freeze Top Row
To freeze panes (first column only):

· Go to the View tab

· In the Window group, select Freeze First Column
To unfreeze panes (any setting):

· Go to the View tab
· In the Window group, select Unfreeze Panes
[image: image17.emf]
Hide rows and columns

Hiding data serves the purpose of allowing you to temporarily make column or rows from your

spreadsheet invisible.
To hide data:

· Right-click a row or column (or a selection of multiple rows or columns)

· Select Hide from the menu
[image: image18.emf]
To unhide data:

· Highlight rows / columns either side of the hidden one/s

· Right-click and select Unhide from the menu
[image: image19.emf]
Grouping Data

You can create groups of data to help you work with large worksheets of data, or anytime that you want to provide some structure to your worksheet or facilitate outlining tools. A group simply creates an object out of selected rows or columns. This object can be expanded or collapsed.
Use the following procedure to create a group. 

1. Select the range of cells you want to group.

2. Select the Data tab from the Ribbon.

3. Select Group.
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Outlining Data

Outlining provides a structure to your worksheet to quickly hide or display detail and summary information. Your worksheet should already contain summary rows. You can outline automatically or manually. When you create subtotals, you automatically create an outline.
Use the following procedure to create an outline. 

1. Select the range of cells to include in the outline.

2. Select the Data tab from the Ribbon.

3. Select the small square in the corner of the Outline group.
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4. In the Settings dialog box, check the direction of the summary rows and columns.

5. Check the Automatic styles box to have Excel automatically apply styles to the outline.

[image: image22.png]Settings
Direction

Summary rows below detail
Sumary colanns ta igh o detal

] automtic styles

et ] (o] [ox ] [ coma





6. Select Create.

Viewing Grouped and Outlined Data

When you have added groups or created an outline, either manually or automatically, Excel includes several features to make it easy to view different parts of the data at once. You can expand or collapse detail data. You can also jump to another group at any time.
To follow is how to work with grouped or outlined data.

The Hide Detail icon allows you to quickly hide the detail data.
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The + icons indicate hiding detail data.

The Show Detail icon allows you to quickly show the detail data. You can select the Show Detail icon multiple times to continue expanding the current level.
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The minus icons allow you to collapse individual groups. The plus icons allow you to expand individual groups.

The numbers in the top left corner indicate a level. Click on a number to show that level.
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Printing Large Worksheets

Printing spreadsheets that are larger than one page often requires adjustment of print settings in order to get a hard copy that paginates in an appropriate fashion.

Print Titles

The Print Titles feature allows you to select rows and/or columns which contain labels that you would like repeated at the top and/or left side of each printed page.

To access Print Titles:

· Select the Page Layout tab

· Go to the Page Setup group

· Click the Print Titles button

· Under Print Titles, select the Rows to repeat at the top and/or Columns to repeat at left

· Click OK
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Page Break Preview

Excel worksheets can get very large. In fact, most real worksheets contain too much data to fit on one

printed page. To print a large worksheet, you have to break up the data into manageable sections. The

point where one contiguous sheet of data is broken into separate pages is called a page break.

If you print an Excel worksheet that is too big for a single page, Excel will define page breaks for you

based on the size of the cells, the size of the paper that your pages will be printed on, and the print scale

you choose. However, Excel doesn’t care very much about the meaning or interpretation of your data

when it sets up page breaks.
On a large worksheet, the data can be broken into pages in awkward, illogical ways. This is why it is a good idea to learn how to manage page breaks on your own.

If you click the Page Break Preview button on the View Ribbon, you will display an Excel view that

shows page breaks in your spreadsheet as blue dotted lines. The solid blue lines indicate the boundaries

of the printed page.

[image: image30.emf]
You can also access Page Break view by clicking Page Break Preview on the status bar.

The Page Break view, though not great for actually working with your data, does provide functionality.

That is, you can still edit, copy, remove data, and choose from menus in this view.
This view is designed to help you organise your spreadsheets for printing. If you find that your data

overlaps onto another page, but you would like to keep it on a single page, you can drag the blue dotted

lines with your mouse to adjust where one page ends and another begins.
[image: image31.emf]
If you use print preview, you can get a better idea of what this page will look like when printed, now that

the page breaks have been adjusted.
Inserting a Page Break

To manually insert a page break:

· Select the header of the column to the right or row below where the page break is to appear

· Right-click on the column or row header

· Select Insert Page Break from the menu
Page breaks can also be inserted from the Page Layout tab, Page Setup group, Insert Break button.

Printing Multiple Sheets

Rather than selecting and printing sheets in the same file individually, multiple sheets can be printed

simultaneously.
To print all sheets in a workbook:

· Right-click on the active sheet tab

· Choose Select All Sheets from the menu

· Use Ctrl + P then press Enter
To print selected sheets from a workbook:

· Click the tab for the first sheet you wish to print

· Hold down the Ctrl key while you click the tabs for the other sheets you want to print. This will

create a group of sheets.

· Use Ctrl + P then press Enter

· To ungroup sheets, right-click on the sheet tab for the first sheet you selected

Choose Ungroup Sheets

· .
Module Two: Working with Multiple Worksheets and Workbooks
In this module we’ll explore the use and management of more than one worksheet using navigating tools,  3-D formulas, linking cells and the consolidation of data.
Using Multiple Worksheets

The default number of worksheets in a work book is three; the maximum number of worksheets is limited only by the memory capacity of your PC.

To create a new worksheet, click the Insert Worksheet tab to the right of the existing sheet tabs in your

workbook (or use the shortcut keys Shift + F11).
[image: image32.emf]
Right-click on a sheet tab to get to the menu below.
[image: image33.emf]
Navigating between sheets

The navigation buttons to the left of the sheet tabs are used to assist with viewing sheet tabs.
The following shortcut keys are also useful:

Ctrl + Page Down 
Make the next tab to the right active

Ctrl + Page Up 

Make the next tab to the left active
Creating 3-D formulas

Instead of calculating with only rows and columns on a single sheet, we can create formulas that

reference cells on multiple sheets.

A reference that refers to the same cell or cell range on multiple sheets is called a 3-D reference.

To create a 3-D formula using a function:

· Select the cell where the formula is to be entered

· Type = (equal sign)

· Type in the function name followed by an open bracketClick on the sheet tab of the first

· worksheet to be entered into the formula

· Hold down the Shift key and click on the sheet tab for the last worksheet to be entered into the

· formula

· On the sheet you have just selected, highlight the cell or range of cells to be included in the

· formula

· To complete the formula, and press the Enter key
Consolidating Data

You can consolidate data to summarize and report results of data that appears on separate worksheets. The worksheets can be in different workbooks. The consolidated data is easier to update and aggregate on a regular basis.
Use the following procedure to consolidate data. 

1. Select the starting cell where you want to display the consolidated data. Make sure to leave enough room for the consolidated data, so that you don’t overwrite other information. In this example, choose the top left cell in Sheet 3.

2. Select the Data tab from the Ribbon.

3. Select Consolidate.
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4. In the Consolidate dialog box, do the following:

· Select the Function from the drop down list. In this example, use Average.

· Select the Reference for each worksheet you are consolidating. If the worksheet is in another workbook, select Browse to open it. Select the cells to include in the consolidation from the first worksheet and select Add. Repeat for each reference.
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Linking Workbooks

As you know, a cell reference like K7 simply refers to the cell at the intersection of column K and row 7. A cell reference like Store!K7 refers to the cell at column K and row 7 in the worksheet named Store. 

Taking this one step further, the reference [Sales.xlsx]Store!K7 refers to cell K7 in worksheet Store in the

workbook Sales.

In Excel, a cell in one worksheet can contain a reference to a cell in another worksheet or in another

workbook. This kind of linking can be useful if you have several sheets that have to reference the same

pool of data. If you create links, the linked cells in the other worksheets or workbooks will be updated

automatically when you update the source data

[image: image36.emf]
In this example above, the linked cells (indicated by arrows) are in two different workbooks.

Using the Paste Link option

To link two workbooks, open both of them and select the cell or range of source data that you want to use from one workbook

[image: image37.emf]
Right click on the cell or range and select Copy from the menu. The copied range will be enhanced with a

flashing black and white border. Once you have done this, right click on the cell in the destination

workbook that will contain the linked data. (If you are linking a range of data, right click on the top left cell of the destination range.) Select Paste Special from the pop up menu and click on the Paste Link button in the lower left.

[image: image38.emf]
The linked data will now appear in the destination workbook. If you update the source data, the linked

data will be updated as well.
[image: image39.emf]
In this image, the cells highlighted in pink have been linked. Cell E14 in the lower workbook has been

linked to cell B5 in the upper workbook, and the range B2:D6 in the lower workbook has been linked to

the range D1:F5 in the upper workbook.

Creating a formula to link workbooks

There is also another way to create links between workbooks. First, click on the destination cell and type

=. Next, click the source data cell in another workbook and press the Enter key. The two workbooks

should now be linked, and any data or changes that appear in the source cell will be seen in the linked

cell as well.
Controlling link updates

When the source workbook and the destination workbook are open on the same computer, links are

updated automatically. When you open a destination workbook, and the source workbook is not open,

you may be alerted by the Trust Bar (see below) whether to update the links.
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You can control whether the Trust Bar alerts you, and whether to update all links when the alert does not appear. You can also update only some of the links, if the workbook contains more than one link.

Manually update all of the links or none of the links in a workbook

Close all workbooks. If one source workbook is open, and others are closed, the updates will not be

uniform. Open the workbook that contains the links. To update the links, on the Trust Bar, click Options,

and then click Enable this Content.
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Manually update only some of the links to other workbooks

Close all workbooks. Open the workbook that contains the links.

On the Data tab, in the Connections group, click Edit Links.
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In the Source list, click the linked object that you want to update.

· To select multiple links, hold down CTRL and click each linked object.

· To select all links, press CTRL+A.

· Click Update Values.
Dealing with Broken Links

If the following message appears on your screen when you are attempting to update a linked file, this

means that Excel cannot find the source file. This may be because the source file has been renamed or

moved to a different location.
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To reestablish the link between the two files, click the Edit Links option to open the Edit Links dialogue

box (below).
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Select the Change Source button from the Edit Links dialogue box.

This will allow you to navigate to the source file. Once you have located the source file, select it and click

OK.
You will then see that the link has been re-established (note OK showing under Status). Any updates of

data should have been completed. Click the Close button.

[image: image45.emf]
The Edit Links dialogue box can be opened at other times by going to the Data tab, Connections group

and clicking the Edit Links button.

[image: image46.emf]

Module Three: Working with Dates
In this module we will be exploring the use of dates within formulas, including date functions, the input of dates and format.

Dates and time in Excel

Though Microsoft Excel displays dates and times as you would expect, it stores them as numbers.

Dates are stored as the number of days since the beginning of the last century (ie 1-Jan-1900 is day 1).

Note that dates before 1900 are stored as text and cannot be used in calculations.

Times are stored as parts of a day – i.e. 12 noon is stored as 1/2 or 0.5. Both the date and time can

therefore be stored as a single number, the fractional part forming the time.

When entering a date into a cell, Excel will accept various different formats (including year/month/day as well as day/month/year).

Months can be entered as a number or text - the name in full or in an abbreviated (three-letter) form.

Years abbreviated to 2 figures are taken to be between 1930 and 2029 - ie 31/12/20 is 31-Dec-2020. If

the year is omitted, the current year is assumed.

A slash or hyphen (minus sign) can be used to separate the day, month and year. Spaces can be used if

the month appears as text.

If Excel recognises data as a date it will appear on the right of the cell - if it appears on the left, Excel

hasn't recognised it.

Times are entered into a cell by using a colon to separate the hour, minute and second. They also appear

right-justified if recognised as valid. Because the time represents the fraction of the day, the hour must

always be included. Times can be entered with an am/pm suffix if desired (a space must precede am/pm).

Both a date and time (separated by a space) can be entered into a cell.
Inserting and formatting dates

Once a date and/or time has been entered into a cell, various format styles can be applied to the data.

To apply a format:

· Enter a date into an empty cell and press <Enter> - widen the column, if necessary

· Press <up arrow> to move back to the cell with the date

· Go to the Home tab, Number group

· Launch the Format Cells dialogue box
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Entering date functions

There are numerous date and time functions in Excel 2010. These can be viewed by selecting the

Formulas tab and clicking the Date & Time button from the Function Library group.

Two common functions are:-

=NOW() Gives today's date and time (eg 21/07/2005 09:30) - the two brackets are required.

=TODAY() Gives today's date in date format (eg 21/07/2005)

Other date and time functions available in Excel 2010 are:
DAY 

Returns the number of the day from 1 to 31.

DAYS360 
Calculates the number of days between two dates based on 360 day years.

HOUR 

Gives the hour as a number from 0 to 23.

MINUTE 
Gives the minute as a number from 0 to 59.

MONTH 
Gives the month as a number from 1 to 12.

SECOND 
Gives the second as a number from 0 to 59.

TIME 

Converts hours minutes and seconds to an Excel serial number time.

WEEKDAY 
Gives the day as a number from one to seven.

YEAR 

Gives the year of a serial number date, from 1900 to 9999.
Using dates in formulas

Because dates (and times) are stored as numbers, they can be used in calculations - for example, it's

easy to work out the number of days between two dates or calculate an employee's wages given an

hourly wage rate. Some other tasks involving times and dates are less straightforward (for example,

sorting dates into calendar order, irrespective of the year).

Date entries can also be used in formulae to give answers to your questions, i.e. working out a date which is 30 days from the present date.
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Module Four: Conditional Formulas and Formatting
In this module we will be exploring the use of calculations and formatting within a data set based on the data meeting specific conditions/criteria.

The IF function

Excel’s IF function can often prove to be very useful. You can use this function to branch to different

values or actions depending on a specified condition. The structure of an If function is as follows: IF

(logical test, value if true, value if false)

IF functions are called conditional functions because the value that the function returns will depend on

whether or not a specific condition is satisfied. As an example, consider the following function: IF (A1=10,5, 1)

This function states that if cell A1 has a value of 10 the cell that contains the function will have the value

of 5. But if A1 doesn’t have a value of 10, the cell that contains the function will have a value of 1. In other words, the function reads: if A1 equals 10 then return the number 5, else, return the number 1.

Let’s say that this next IF function is entered into cell B2: IF (A1<=100, A1*.5, C3*2)

This function states that if the contents of cell A1 is less than or equal to 100, the value in cell B2 will be

the value in A1 multiplied by .5; else, the value in B2 will be the value of cell C3 multiplied by 2.

You can insert an IF function by invoking the Insert Function dialogue and looking under the Logical

category, or by typing it directly into the formula bar.

The logic of the IF function can be a little confusing until you get used to it. The best way to get

comfortable with IF functions, is to practice using them.
Using the Function Library

Excel 2010 contains an extensive library of functions that you can call upon to help you solve problems.

These tools are available in the Function Library button group, on the Formulas ribbon.
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The first and largest button is Insert Function. This button will open a dialog allowing you to search for

and insert hundreds of functions.

You can also click the small fx button next to the formula bar to display the Insert Function box.
Clicking the Insert Function button activates the Insert Function dialogue box and provides access to the

large range of functions available in Excel
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Once the Insert Function dialogue box is open:

· Select the function you wish to use from the available list and click OK or

· Type the name of the function you wish to use in the Search for a function area, press Enter,

select the function when it appears in the list and click OK.

Manually entering a function

If you know which function you wish to use, you can enter a function into a worksheet by inputting it

manually (i.e. by typing the function directly into a cell).

When you do this in Excel 2010, a screen tip will appear with the possible functions that correspond with

the letters of the function name you have entered.

For example, if you type =IF into a cell the following appears.
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If there is more than one function listed, you can toggle between them by using the arrow up or arrow

down keys.
Once you have selected the function you wish to use, continue by typing in a left bracket, which will cause the function syntax to display in another screen tip.
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Continue to enter all the arguments required for the function to give you a result, ensuring you type a

comma between each argument.

[image: image54.emf]
Press Enter to display the result
Conditional Formatting

In Excel 2010 you can design a worksheet in such a way that data is formatted differently, based on the

values the data assume at any given time. This is called conditional formatting.
This spreadsheet is conditionally formatted to highlight cells in different colours depending on the cell

values.
[image: image55.emf]
Use the following procedure to apply conditional formatting. In this example, we will format all monthly totals in the budget that are over $2500.
1. Highlight the cell or cell range where you want to use conditional formatting. 

2. Select the Conditional Formatting tool from the Home tab on the Ribbon. Select Highlight Cell Rules. Select Greater Than.
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Excel displays the Greater Than dialog box to help you complete the conditional formatting rule.

[image: image57.png]Format cells that are GREATER THAI:

B =R





3. Enter 2500 in the left field. 

4. Select a formatting option from the right drop down list.

5. Select OK to apply the conditional formatting.
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When the Conditional Formatting menu is active it will display a menu of conditional formatting options. From this menu, you can choose:

Highlight Cells Rules 
This will highlight cells that are greater than, less than, between or equal to

values that you can specify.

Top/Bottom Rules 
This option will allow you to highlight the top or bottom numbers or percent in the selected cells.

Data Bars 
Will display coloured bars that are indicative of the value in the cell. 
Colour Scales 
Will use different shades of colour to represent different values, from low to high.

Icon Sets 

Will use sets of similar icons that will visually indicate a cell’s value.
You will also notice at the bottom of the menu options for creating a new rule, for clearing rules, and for managing rules.

Each one of the conditional formatting menu options will display either a sub menu or a dialogue box. In the image above, you can see the sub menu for the Data Bars option. As you let your mouse pointer hover over an option in the sub menu, you will see a preview of the type of conditional formatting that your pointer is on applied to the cells that you selected. To implement the conditional formatting, just click the submenu option of your choice.

You can apply multiple conditional formatting rules to a group of cells by simply re-selecting the group, and then adding another conditional format by using the menu system discussed previously. The following image shows a group of cells with a data bar conditional format and an icon set conditional format.

Use the following procedure to create a new conditional formatting rule.

1. Highlight the cell or cell range where you want to use conditional formatting. 

2. Select the Conditional Formatting tool from the Home tab on the Ribbon. Select New Rule.

Excel opens the New Formatting Rule dialog box.
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3. The options in this dialog box differ, based on the Rule Type you select. Select the Rule Type and follow the prompts to indicate the conditions for when to apply the formatting.

4. Select Format to open the FormatCells dialog box to create the formatting to apply when the conditions are met.

5. Select OK to save your rule and close the New Formatting Rule dialog box.

Removing Conditional Formatting

If you want to remove conditional formatting rules, simply use the Clear Rules option from the menu. This option will let you clear rules for selected cells or for an entire spreadsheet. 
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Module Five: Documenting and Auditing

This module introduces concepts that will help you troubleshoot formulas as we progress through the course. Precedent cells are cells whose contents are used in the active cell. Dependent cells are used in other cells contents or formulas. This module explains how to show these relationships. It also explains how to display the formulas, instead of the results, in a worksheet. You’ll also learn how to work with comments in this module.

Formula errors can be very frustrating. This module will teach you how to prevent formula errors by using named ranges. You’ll gain an understanding of formula errors and take a closer look at tracing dependents and precedents. This module explains how to use the trace errors commands. You’ll also learn how to evaluate formulas
Tracing Precedent Cells

If you have formulas that are based on the contents of another cell, you have precedent cells. If you have problems with a formula or result, you can trace the precedent cells to help track down the problem. The Trace Precedents command is useful to see the trail of data relationships. The Trace Precedents command allows you to show tracer arrows to show the relationship between the active cell and the precedents to that cell.
Use the following procedure to trace precedents. 

1. Select the cell that contains the formula you want to trace. Cell D18 is used in this example.

2. Select the Formulas tab from the Ribbon.

3. Select Trace Precedents.
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4. Excel adds a tracer arrow from each cell that provides data to the active cell.
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Tracing the Dependents of a Cell

If you have formulas that are based on the contents of another cell, you have dependent cells. The Trace Dependents command is useful to see how other cells are influenced by the active cell’s contents . The Trace Dependents command allows you to show tracer arrows to show the relationship between the active cell and the dependents of that cell.
Use the following procedure to trace dependents. 

1. Select the cell that you want to trace. Cell D18 is used in this example.

2. Select the Formulas tab from the Ribbon.

3. Select Trace Dependents.

[image: image63.png]Q32010 time tracking.xlsx - Microsoft Excel o @ =

EETM cone et Foscaout | Fomus | Data  Reviw  View  Addins c@o@x

ﬁ 5 atosum - @ logial- [ Lookup &Reterence - <) ZaDefine Name - B Trace Precedents 5] Show Formuias é’g
RecentyUsea - A Tot - st &7 - P seinFomis - o checing -

Insert & v @ i M Name Ea ® N Watch | Calculation

Function (8 Financial = {7 Date & Time - More Functions - Manager B Create from Selection | 7, Remove Arrows = (&) Evaluate Formula  Window | Options

Function Library | Defined Names | Formula Auditing | Calculation |





4. Excel adds a tracer arrow to each cell that uses the active cell’s data.

5. Click the Trace Dependents tool again to see further relationships that are influenced by the active cell’s contents.
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Displaying Formulas Within the Sheet

In the default view, your worksheet shows the results of your formulas. When you select a cell, the formula bar shows the formula of the active cell. To help you audit your worksheet, you can show all of the formulas at once. The formulas display in the appropriate cells instead of the formula results.
Use the following procedure to display formulas within the sheet. 

1. Select the Formulas tab from the Ribbon.

2. Select Show Formulas.
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Excel expands the cells as necessary and displays all the worksheet’s formulas in their cells.
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Adding, Displaying, Editing, and Removing Comments

Comments are notes that you can add to a cell to explain the contents, such as to remind yourself of something related to the cell or explain it to other worksheet uses. The Comments section on the Review tab of the Ribbon includes the tools to insert, edit, show or hide, and remove comments.
Use the following procedure to add a comment. 

1. Select the cell where you want to add a comment.

2. Select the Review tab from the Ribbon.

3. Select New Comment.
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4. Begin typing your comment.
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Use the following procedure to show or hide comments. 

1. Select the cell with the comment.

2. Select Show/Hide Comment or Show All Comments.
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Use the following procedure to edit a comment. 

1. Select the cell with the comment.

2. Select Edit Comment.

Excel opens the comment for editing. You can select text to change it, delete, or add text to the comment.
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Use the following procedure to remove a comment. 

1. Select the cell with the comment.

2. Select Delete.

Understanding Formula Errors


the most common formula errors and how they occur.

Start every function with the equal sign (=)


Excel will display the formula contents as text or a date if you do not use the equal sign.
Match all open and close parentheses    
Every parenthesis needs a pair. Parenthesis must be in the correct position for the formula to work correctly.
Use a colon to indicate a range    

When working with a range of cells, you must use a colon between the first and last cell reference.
Enter all required arguments    

Some functions require arguments and some do not. If the function requires arguments, make sure you have the right number.
Enter the correct type of arguments    

For functions that require arguments, make sure you have the right ones.
Nest no more than 64 functions    

The top limit of nested functions, or functions within a function, is 64.
Enclose other sheet names in single quotation marks    

If your worksheet names contain non-alphabetical characters, you must enclose the sheet name within single quotation marks when using the name in a formula.
Place an exclamation point (!) after a worksheet name when you refer to it in a formula    

If you are using a worksheet name in a formula, the name must be followed by an exclamation point.
Include the path to external workbooks    

If you are referencing cells from another workbook, make sure the formula includes both the workbook name and the path to the workbook.
Enter numbers without formatting    

Excel treats commas as separator characters. Format the formula result after you enter the numbers in the formula.
Avoid dividing by zero  
If you divide a cell by another that is zero or no value can result in a #DIV/0! Error.
Using the Trace Errors Commands

When you have a cell with an error, the cell displays a green triangle in the upper left corner. The Trace Errors icon appears next to the cell. The icon gives you several options to help correct your error.
Use the following procedure to  use the Trace Errors Commands on a cell with a formula error

1. A formula with an error displays a green triangle in the upper left corner, along with an error icon next to the cell. Click on the arrow next to the icon to see the options.
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· Help on this Error – opens the Excel help files directly to an article related to the type of error Excel detected.

· Show Calculation steps – opens the Evaluate Formula dialog box (discussed later in this module).

· Ignore Error – allows you to keep the error and removes the error icon and green triangle.

· Edit in Formula Bar – moves your cursor to the Formula bar to allow you to correct the formula.

· Error Checking Options – opens the Options window to allow you to adjust the error checking options (discussed later in this module).

Using Error Checking

The Error Checking function in Excel is something like the Spell checking function in other applications. The Error Checking function checks for certain types of errors. The options on the dialog box help you to correct any errors that it finds.
Below is the Error Checking dialog box. 

1. From anywhere on the worksheet, select the Formulas tab.

2. Select Error Checking.
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The Error Checking dialog box displays the formula as written in the cells. It explains why the formula contains an error.

· Help on this Error – opens the Excel help files directly to an article related to the type of error Excel detected.

· Show Calculation steps – opens the Evaluate Formula dialog box (discussed later in this module).

· Ignore Error – allows you to keep the error and removes the green triangle from the cell.

· Edit in Formula Bar – moves your cursor to the Formula bar to allow you to correct the formula.

· Options – opens the Options window to allow you to adjust the error checking options.

· Resume – restarts the Error Checking if you have switched to another task.

· Previous – returns to the previous error.

· Next – moves to the next error.

You can open the Formulas options from the Error Checking dialog box or the Trace Errors commands next to an error cell. 

You can also open the Options dialog box selecting the File tab from the Ribbon. Then select Options. Select Formulas.

[image: image74.png]Excel Options

(—
e

(R—

sounes

Quick Access Toolbar

Trust Center

Change options related to formula calculation, performance, and error handiing.

Calculation options
Workbook Calculation: [ Enable fterative calculation

© Automatic Maimum Iterations: (100
© Automatic except for data tables.

O Manual
Recalculate workbook before saving

Maximum Change:

‘Working with formulas.
[ RiCt reference style
Formula AutoComplete
Use table names in formulas.
Use GetPivotData functions for PivotTable references

Error Checking

Enable background error checking

Reset lanored Errors.

Indicate grrors using this color:

Ertor checking rules

Cells containing formulas that resut in an error Formulas which omit cells in 2 region’
Inconsistent calculated column formula in tables Unlocked cells containing formulas
Cells containing years represented as 2 digits () [ Formulas referring to empty cells
Numbers formatted as text or preceded by an apostrophe

Formulas inconsistent with other formulas in the region





Under Error Checking, you can turn off Background error checking by clearing the box. 

You can change the color of the triangle displayed in cells where Excel has detected a formula error. 

Select the Reset Ignored Errors to re-enable Excel to help you with any errors that you have previously ignored.

In the Error Checking Rules area, you can check or clear the following checkboxes:

· Cells containing Formulas that result in an error – When checked, Excel checks for formulas that do not use expected syntax, arguments, or data types. 
· Inconsistent calculated column formula in tables – When checked, Excel checks for inconsistencies in calculated columns, such as when you enter data other than a formula in a column that has all calculated cells.
· Cells containing years represented in 2 digits – When checked, Excel will create an error if you enter a date with a year represented as two digits.
· Numbers formatted in text or preceded by an apostrophe – When checked, Excel will create an error if you enter or import numbers preceded by an apostrophe or text.
· Formulas inconsistent with other formulas in the region – When checked, Excel looks for formulas that are different from formulas near it. Often these formulas should be the same, except for the cell references used.
· Formulas which omit cells in a region – When checked, Excel compares the reference in a formula against the actual range of cells adjacent to it.
· Unlocked cells containing formulas – Formulas are locked for protection by default and must be unlocked before editing. If you have unlocked cells with formulas, Excel marks it as an error when this box is checked.
· Formulas referring to empty cells – When checked, Excel creates an error if a formula includes a reference to an empty cell.
· Data entered in a table is invalid – When checked, Excel creates an error if there is a validation error in a table.
Evaluating Formulas

The Evaluate Formula dialog box allows you to calculate – one at a time – the intermediate calculations and logical tests in a nested formula.
Use the following procedure to evaluate a formula. 

1. Select the cell that contains the formula you want to evaluate.

2. Select the Formulas tab.

3. Select Evaluate Formula.
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4. Select Evaluate to see the results of the underlined portion of the formula.
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5. Continue selecting Evaluate to see the results of each piece of the formula.
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· If the underlined part of the formula is a reference to another formula, select Step In to display the other formula in the Evaluation box. Select Step Out to go back to the previous cell and formula. The Step In button is not available the second time a reference appears in the formula, or if the formula refers to a cell in a separate workbook.

· To see the evaluation again, click Restart.

6. Select Close when you have finished.

Evaluate each of the formulas and think about why the results are different, even though the same formula is used for each column of cells.

Module Six: List Management
In this module, you’ll learn how to work with lists and manage them using the transpose data tool, text to columns tool and  sorting and filtering tools.

Transposing Data from Rows to Columns
You’ve spent some time setting up a worksheet and now you realize that you really need some of the data in columns instead of rows. Don’t worry. There’s an easy way to do that. Just copy the values, select the new area where you want to paste them, and select the Transpose option when you paste the values.
Use the following procedure to transpose data. 
Copy the range of cells you want to transpose. This feature will not work if you cut the cells.

1. Place your cursor in the new location and right-click.

2. Select Transpose from the Paste Options on the context menu.
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Using the Text to Columns Feature

The text to columns feature allows you to use data in another format (such as a text file) and convert the text into columns. This is useful such as when you have a list of names that you want separated into first and last name columns.
Use the following procedure to convert text to columns. 
Paste text from another application. 

1. Select the text.

2. Select the Data tab from the Ribbon.

3. Select Text to Columns.
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4. In the Convert Text to Columns Wizard, choose the file type that best describes your data. Select Next.
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5. In the next screen, select the type of divider. In this example, a space separates the items we want to convert to columns. Your text could be divided by almost any character. Select Next.
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6. In the next screen, you see a preview of the data converted to columns. For each column:

· Define the data format (General, Text, Date) or choose to skip that column.
· Enter or select the destination on the worksheet.
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Using the Advanced button, you can also choose your settings for numeric data. 
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7. When you have finished, select Finish.
You can now work with your data as separate columns.

Checking for Duplicates
Use the following procedure to check for duplicate data. 

1. Highlight the area from which you want to remove duplicates.

2. Select the Data tab from the Ribbon.

3. Select Remove Duplicates.
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4. Select the columns you want to check for duplicates. The Select All and Unselect All tools can help you manage a large list of columns. The My Data has Headers box indicates whether the list includes header rows.
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5. Select OK.

Excel notifies you of how many duplicates are removed.
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Sorting Data

Excel allows you to sort your data in ascending or descending order by one or more columns. Data sorting works best when your columns have a label. When you sort, Excel keeps your rows together.
Use the following procedure to sort. The part number column is used in this example.

1. Click on the column header.

2. Select the Sort & Filter tool from the Ribbon.
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3. Select Sort A to Z or Sort Z to A.


Use the following procedure to create a custom sort.

1. Click on one column header you want to use in your sort.

2. Select the Sort & Filter tool from the Ribbon.

3. Select Custom Sort.

Excel opens the Sort dialog box.

4. You can choose the first column by which to sort from the Sort By drop down list. The options displayed match the column headers in your worksheet.

5. Select an option from the Sort On drop down list. Values is selected by default.

6. Select an Order from the drop down list.

7. To add another column to your sort, select Add Level. Repeat steps 4, 5, and 6 for the next sorting level. You can Delete the Level, Copy a Level, and rearrange the order of the sorting levels by using the up or down arrows.

8. Select OK when you have finished setting up your sort to see the results.
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Filtering Data

Filters allow you to view only data that matches certain criteria. Simple filters filter the data based on your select. There are also different types of more advanced filters, depending on your data. For example, number filters allow you to answer a variety of questions, using “less than,” “greater than,” or “top ten.” Text filters allow you to answer questions like “begins with,” “ends with,” or “contains.” There are also specialized filters for dates and other types of data.

Filtering works best when all columns have headers. Excel places a small arrow in the column header to apply a filter.

Use the following procedure to apply a simple filter.

1. Click in the column header for the column including the value you want to filter. Select the Sort & Filter tool from the Ribbon. Select Filter.
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Excel places a small icon in each column header for filtering.
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2. Select the icon to see the Filter options.
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3. You can uncheck the Select All check box to clear all of the values. Select the option(s) that include the values you want to see. For example, in the above illustration, Excel will only show the rows that include the value $255.23 in this column. You can check multiple values.

4. Select OK to apply the filter. Excel includes a different small icon in the column header to indicate that a filter has been applied. It only shows the rows that match the filter. The other rows are still present, but hidden.
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Use the following procedure to clear a filter.

1. Click the Filter icon next to the column header to open the Sort and Filter context menu.
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2. Select Clear Filter From to clear the filter.

Use the following procedure to use a number filter. This example demonstrates a “Greater Than” number filter.

1. If you have not previously performed a filter on this worksheet, you may need to select the Sort & Filter tool from the Ribbon. Select Filter. Select the Filter icon next to the column header you want to filter. 

2. Select Number Filters. Select Greater Than.
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Excel displays the Custom Auto Filter dialog box.
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3. Select the value from the second drop down list.

4. If you want to add to you filter, select either And or and select another column header from the drop down list. Select another value from the drop down list.

5. Select OK to apply the filter.
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Using an Advanced Filter

If you can’t get the results you want from a custom filter, you can construct your own advanced filters to

get the most control over your data tables.

To make an advanced filter, you have to set up a range of criteria to filter your table with.
[image: image99.emf]
In this example, we want to show only the records where the Age field is less than 40. To do this, you can type a column heading in cell F1. This heading must be exactly the same as the corresponding heading in the data table that you want to base the filter on.

In cell F2, you can enter the criteria. In this instance, cell F2 contains <40 as you only want to show

records with an age field value that is less than 40. To apply the filter, click on any cell in the data table

and then click the Advanced button on the Data Ribbon.

You will now see the data table outlined with a flashing dashed border, and the Advanced Filter dialogue

box will be displayed.
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When you see the box, make sure the table range is indeed the range you want to filter. You can then

click in the data area labeled Criteria Range and select the cells that contain your filtering criteria (cells

F1:F2 in this case).

The Filter the List in-Place radio button is selected, so the filtered records will appear in the same location as the original table. Click OK to filter the List range using the Criteria range as specified in the Advanced Filter dialogue

[image: image101.emf]
The table has been filtered to show only those records that have an age field value that is less than 40.

To display the full table again, click the Clear button in the sort and filter button group on the Data Ribbon.

You can set up more complex filters by adding to your criteria range. For example, the following criteria

range will filter the records so that only those with an age less than 40, a height greater than 63, and a

weight less than 180 will be shown. Notice that the column headings in the criteria range are identical to

those in the original table.
[image: image102.emf]
This next criteria range will show records that have a height greater than 63 or a weight less than 180.

The conditions are offset by one row from each other, indicating the use of a logical Or operator.
[image: image103.emf]
Copying Filtered Records

It may be the case that you want to extract your filtered records to a new place in the worksheet or even to a new worksheet altogether. Copying your filtered records to a new location leaves the view of your original data table unchanged.

To copy your filtered records to a new location, set up a criteria range as before, with column headings

and the conditions you want to specify. In addition, you can prepare a range for the filtered records to be copied to. To do this, you can choose some empty columns and label them with the headings for the

fields you want to display. You do not have to display an entire record, just the fields of your choice.

Make sure the column headings for the range you are copying to are exactly the same as the column

headings in the original unfiltered table. If you do not put column headings in the copy to range, all of the fields specified in the table range will be copied. If you are copying entire records, you can leave the

range you are copying to blank.
Click a cell in the data table, and click the Advanced button in the Sort and Filter group on the Data

Ribbon to display the Advanced Filter box. Set your options as before, but this time, choose Copy to

Another Location from the radio options at the top.

[image: image104.emf]
Select the range that you that you have prepared for the copied records with your mouse or type it in

directly. If you don’t know how large a range to select, select the column letters above the fields you have chosen in the destination range. If you are copying all fields (i.e. complete records), just click on a cell in the upper left of the range you are copying to. Click OK to copy the filtered records to the destination range.
The image that follows shows the fields Weight and Age filtered from the main table and copied to

columns I and J, according to the condition that height is less than 70 .Because the column headings

Weight and Age have been specified in the destination range, only the weight and age of people with a

height less than 70 will be shown in the destination area.
[image: image105.emf]
You can also specify unique records only by clicking the appropriate checkbox in the Advanced Filter

dialogue box. This will ensure that duplicate records are not selected or copied.

Creating Subtotals

Another kind of outlining or grouping technique available in Excel is the subtotals feature. If you have

numeric data organised with clear column and row headings, you can use Excel to create automatic

subtotals and grand totals for the data.

The following worksheet contains sales information for different products across geographical regions.
[image: image106.emf]
To use Excel’s subtotal feature, select the range of data you want to apply subtotals to and click the

Subtotal button on the Data Ribbon. Be sure to include the column labels in your selection so Excel will

be able to discern what numbers to total. For this example, you could select A1:E10 and click the Subtotal button on the Data Ribbon to invoke the following Subtotal dialogue.
[image: image107.emf]
The drop list under the “At each change in” heading gives you options as to the number of rows that will

be totaled. (Totals will be applied every time the values under the chosen column label changes.)

The “Use function” drop list lets you choose from a list of functions including SUM, AVERAGE, COUNT,

PRODUCT, and STDEV to apply to your data. The function you choose (normally SUM) will be used to

calculate the totals.
Under the “Add subtotals to” option list, you can select which columns to apply the totals to. You can

apply totals to a single column or to multiple columns in the selected range.

Finally, there are three check boxes at the bottom of the dialogue box that will allow you to:

_ Replace any pre existing subtotals

_ Put page breaks between totaled groups so they will be printed on separate pages

_ Place the subtotals and grand totals above or below the corresponding data

If you choose to apply totals to each change in the region column while using the Sum function for the

profit column, and with no page breaks, the resulting worksheet will look like this.
[image: image108.emf]
Notice that there is a subtotal for the profit figures at every change in the region value. There is also a

grand total for the Profit column at the end of the data. You can also that Excel has provided outlined

levels, collapse/expand buttons, and numbered outline level buttons associated with the totals. These

buttons and outlines work exactly as previously explained. The lower the number on the button, the less

detailed information will be shown.

To remove these subtotals, select the range of data in question (A1:E14) and click the Subtotal button to

invoke the subtotal dialogue box. When you see the box, click the Remove All button.
[image: image109.emf]
Module Eight: Using Templates
This module focuses on helping to understand how to use inbuilt templates, and modify and create custom templates.

By the end of this module, you will be able to:  Access and use Excel’s in-built templates & create, modify and use custom templates.

A template is a workbook design or layout that can be saved and reused for any number of workbooks. A template can have formulas, fill effects, labels, borders, worksheet names, formats, and a host of other Excel features that will be applied to each new workbook that uses the template.
This is an example of an Excel template.

[image: image110.emf]
Opening a Template

To open a workbook using a template, start Excel 2010, and then choose the File tab, from the Office

Menu on the left hand side select New. When you do this, you will display the Available Templates window.
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You can select a template grouping from the categories listed in the middle panel. When you click on a category option, the large viewing pane will display the templates available in the chosen category. If you double click on a template icon in the main viewing area, a workbook will open based on the selected template.

If you click the My Templates option, you will display a New dialogue box that contains templates stored

locally on your computer.

Downloading a Template

When you display the Available Templates window (by clicking the New option) you will see a variety of options listed under the From Microsoft Office Online heading in the middle pane.
You can choose from business templates, calendars, finance and accounting templates, specialty papers,

and more. When you select one of these online options, you will often see a list of template subcategories in the viewing pane on the right.

This list of subcategories is actually downloaded from the Microsoft Office Online Web site. If you do not

have an Internet connection, you will not see the list of subcategories and moreover, you will not be able to download any templates.

If you do have an Internet connection, you can click on one of the subcategory options to see a preview

list of downloadable templates.
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When you see a template that you like, select it by single clicking on it, and then click the Download

button to download the template. Once the template is downloaded, Excel will automatically open a

workbook based on the template. You can also simply double click on the template icon to download the template and create a workbook.
Creating a Template

To create your own template, open Excel 2010 and design your worksheet or workbook layout to meet

any specifications you require. You can add labels, formatting, colour, borders, and formulas. If need be,

you can even create layouts on different sheets in the workbook, as a template can contain as many

worksheets as you need.

Remember, the main purpose of a template is for repeated use of a workbook layout. Keep this in mind

when creating a template. Plan your layout, labels, and formats to make your templates comprehensive

and complete.

When you have completed your design, choose Save As from the File tab to display the Save As

dialogue box. In the dialogue, enter a name for your template in the File Name text field. Next, display the Save As Type drop list near the bottom of the dialogue box and select the Excel template option. (You may have to scroll through the list of options to find it). This will save the file as filename.xltx. When you choose the Excel Template option from the Save As Type drop list, the Save In text field will automatically be filled in with the word Templates.
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This means that your new template will be automatically saved in the Excel Templates folder. (You can

choose another folder to save your templates in if you wish, but if you do, they will not be available when you click the My Templates option in the Available Templates window).

Once you save the file as a template in the Templates folder, it will be available under the My Templates

option in the New window. If you intend to use the template with earlier versions of Excel, save it under

the Excel 97-2003 Template option for backwards compatibility. If you have a macro or macros in your

template, save it under the Excel Macro-Enabled Template option.

Rather than create a template from scratch, you can always download a template that is close to what

you are looking for and modify it in Excel to make it suit your needs exactly. After you finish customizing

the template; save it with a new name in your templates folder as described above. Simply remember to

save it as a template rather than a workbook.
Microsoft Application Series











Excel 2010





Intermediate











Best STL


 Courses never cancelled: guaranteed


 Last minute rescheduling


 12 months access to Microsoft trainers


 12+ months schedule


 UK wide delivery








�
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Insert		Inserts a sheet tab to the left of the present sheet.





Delete	Permanently deletes the sheet, cannot delete if there is only one sheet.





Rename		To display a different name on the sheet tab.





Move or Copy 	Move or copy the sheet within the workbook or to a different workbook.





View Code	View the VBA code in any modules in the workbook.





Protect Sheet	Apply protection to the worksheet.





Tab Colour	Apply colour to the sheet tab.
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We can chart our future clearly and wisely only when we know the path which has led to the present.


Adlai E. Stevenson








Quick Tip: You can access the PivotTable Wizard by pressing ALT, D, P.








Learning is the beginning of wealth.


Jim Rohn








Quick Tip: Use data tables to explore results of changing one or two variables. Use Scenarios if you want to change more than two variables.





Data is not information, information is not knowledge, knowledge is not understanding, understanding is not wisdom.	


Clifford Stoll





Quick Tip: You can create a group with the keyboard shortcut Shift + Alt+ Right arrow. Ungroup the data with the keyboard shortcut Shift + Alt + Left arrow.
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