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 Managing and Balancing Resources and Costs 

Recap on Dependencies and Constraints 

Predecessors and successors 

When tasks are connected they take on the following roles: 

Predecessor is the task whose start or finish drives the start or finish of the successor  

Successor is the task whose start or finish is driven by the predecessor task  

There are four types of dependency that can link Predecessors and Successors. You 

choose the type that best describes the relationship between them: 
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AAS
ta

rt

F
in

is
h

BS
ta

rt

F
in

is
h

Finish-to-Start

 

 

Start to Start (SS) - Start of Predecessor drives Start of Successor 
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Finish to Finish (FF) - Finish of Predecessor drives Finish of Successor 
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Start to Finish (SF) - Start of Predecessor drives Finish of Successor 
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Constraints 

Use constraints to model dates that affect the start or finish of your tasks. In addition to 
the constraint and date you set, Project will also take into account other factors such as 
calendars, resource availability and dependencies when calculating where to place the 

task on the chart.  

All automatically scheduled tasks have a constraint. By default this is set to As Soon As 
Possible (ASAP). This means that unless another task or link gets in the way Project will 
position the task as early in the plan as it can. 

Constraints can be modified by: 

Double clicking on the name of the task to be constrained then from the advanced tab 
choose the constraint type and if appropriate add a date: 
 

As Late As Possible (ALAP) the task will take place as late it can 
 

Finish No Earlier Than (FNET) models a task that is not able to finish before a 

certain date, but could be delayed beyond it 
 

Finish No Later Than (FNLT) is used to describe tasks that are not able to finish 
beyond a date, but are able to finish earlier 

 
Must Finish On (MFO) positions the task’s finish on the specified date 

 

Must Start On (MSO) as MFO but positions the task’s start on the 
specified date.  

 
Start No Earlier Than (SNET) the task starts on or after the specified date but no 

earlier 
 

Start No Later Than (SNLT) for activities that must start on or before a 
specified date.  
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Working with Resources 

Resources are best defined using the Resource Sheet, which can be accessed via the 

View menu or the View bar.  

 

Creating work and material resources 

Each resource is entered on its own line as follows: 

Basic resource properties 

Name Enter an appropriate name for the resource. This can either be 
the name of an individual, a job role or a team name for 
generic resources. 

Type Up to Project 2003 resources can be either work or material. 

Use the Work resource type for people and equipment whose 
availability is capped (Max Units) so you can see if they 
become over-allocated. Use the material resource type if the 

resource is a consumable. 

Project 2007 supports cost resources. Use the cost resource 
type to track variable items such as expenses. The rate for the 
resource is not stored in the resource sheet. Each time cost is 

assigned to a task you can enter the cost that applies just to 
that task. 

Material Label Only applicable for material resources. This is the quantity that 

the resource is purchased in. For example paint might be 
purchased in litres. 

Initials An alternative to having the full name beside bars on the  

GANTT chart 

Group Can be used to categorise resources appropriately for reports, 

filters and grouping. Typical uses are team names, 
departments, subcontractors etc. 

Max Units The maximum number of units of the resource. 100% 
generally means one individual; 300% 3 individuals. (Work 

type only) 

Standard Rate  Cost of standard work, can be recorded as 
Hourly/Daily/Weekly/Monthly e.g. £200/d for a daily rate  

Overtime Rate  Cost of resource when work is specified as overtime. (work 

type only) 
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Cost/Use  A one off cost associated with the resource. Is charged every 
time resource is allocated to a task. Can also be used in 
addition to Standard Rate. 

Accrue At  Determines if the resource costs are charged at the start of the 

task; throughout the task, or at its end. 

Base Calendar The base calendar which determines the resource’s working 
time. (Work Type only) 

Code A general code that can be used to identify the resource or 
resource group. A typical example would be a cost centre code. 

 

Creating cost resources (2007 only) 

Cost resources (such as travel or accommodation) are created as a type of resource in 

the Resource Sheet.   
 

 

Cost resources are used when you want to apply (to a single task) multiple separate 
miscellaneous costs that aren't changed by the amount of work performed on the task. 
For example, an executive working on a new project proposal might have three separate 
cost resources applied to him or her: one for airfare, one for food expenses, and one for 

hotel room expenses. In this way, several "fixed" costs can be applied to a single task. 
Unlike with work resources and material resources, cost rates cannot be applied to cost 
resources. 
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After you create the cost resource, you assign it to tasks using the Assign Resources 
dialog box.  It is at this point that you type in the amount: 

 

 

Working with multiple calendars 

Assigning and amending a resource calendar (2003) 

1. In the Resource Sheet Base Calendar column, select the relevant 

Base Calendar: 
 

 
 

2. Double click the Resource to display the Resource Information Dialog Box and 
click the Working Time tab. 
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2003

 

3. Select the relevant dates and set the selected date(s) to nonworking time or 
to non default working time 

 

2003

 

 

Note: the name of the underlying Base Calendar is displayed beneath the 
name of the Resource.  Any subsequent changes you make to a Base 

Calendar will be automatically reflected in any dependant Resource 

Calendars. 

To access the additional resource properties, double click on the resource in the resource 

sheet and then modify the properties in the Resource Properties Dialog.  

 

General 

(Availability) 

Allows user to specify different availability levels for different time 

periods. For example a resource might only be available for 50% of 
its time for the month of March. This can be modelled by selecting 
the start and end date, together with the level of availability during 
this period. From Project 2007 this also includes the Change 

working time button.  
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Calendar Use this to identify holidays and other non working days for the 
resource. Simply select the non-working day on the calendar and 
click on the “Non Working Time” option button. From 2007 this has 
been included on the general tab under the Change working time 

button. 

Costs Use this to: 

1. Model inflation. If the resource’s costs are likely to change 

during the course of the project, simply select the date of the 
change in a new row on the cost sheet, and then enter the new 
costs. The new costs can be entered directly, or as an increase 
on the previous figure e.g. +10% would increase the cost by 

10%. 

2. Add additional costs rates. A typical use would be for a resource 
that is paid different results for different tasks. For example a 
resource might be paid one rate for training and another for 

consulting. To add the rate simply select one of the additional 
tabs (B-E) on the cost sheet and enter the rates as appropriate. 

Notes Used to add freeform notes or attach documents relating to the 
resource. 

Assigning and amending a resource calendar (2007) 

1. In the Resource Sheet Base Calendar column, select the relevant 
Base Calendar: 

 

 
 

2. Double click the Resource to display the Resource Information Dialog Box and 
click the  Change Working Time button 

 

2007
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3. Edit on the Exceptions or Workweeks tabs 
 

2007

 

 

Note: the name of the underlying Base Calendar is displayed beneath the 

name of the Resource.  Any subsequent changes you make to a Base 
Calendar will be automatically reflected in any dependant Resource 

Calendars. 

 

To access the additional resource properties, double click on the resource in the resource 

sheet and then modify the properties in the Resource Properties Dialog.  

 

General 

(Availability) 

Allows user to specify different availability levels for different time 
periods. For example a resource might only be available for 50% of 

its time for the month of March. This can be modelled by selecting 
the start and end date, together with the level of availability during 
this period. From Project 2007 this also includes the Change 

working time button.  
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Calendar Use this to identify holidays and other non working days for the 
resource. Simply select the non-working day on the calendar and 
click on the “Non Working Time” option button. From 2007 this has 
been included on the general tab under the Change working time 

button. 

Costs Use this to: 

3. Model inflation. If the resource’s costs are likely to change 

during the course of the project, simply select the date of the 
change in a new row on the cost sheet, and then enter the new 
costs. The new costs can be entered directly, or as an increase 
on the previous figure e.g. +10% would increase the cost by 

10%. 

4. Add additional costs rates. A typical use would be for a resource 
that is paid different results for different tasks. For example a 
resource might be paid one rate for training and another for 

consulting. To add the rate simply select one of the additional 
tabs (B-E) on the cost sheet and enter the rates as appropriate. 

Notes Used to add freeform notes or attach documents relating to the 
resource. 
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Assigning Resources to Tasks 

There are two stages of resource allocation. The Initial allocation, where resources are 

first allocated to a task; and then any changes made to that allocation, for example 
adding extra resources, or removing resources. 

Initial allocation 

The initial allocation of resources involves specifying the resources necessary to complete 
each task in the duration specified. 

Procedure 

1. In the Gantt chart view 
2. Split the window to show the Task Form view below the Gantt Chart 
3. Select the task which is to be resourced 

 

Then in the lower pane, under resources: 
 

4. Select each resource required for the task 

5. Then Click OK (Note all required resources must be selected before OK is clicked) 
 

Allocating multiple resources 

When multiple resources are allocated to a task Project will assume that each resource 

must work on the task for the specified duration. So if two resources are to work on a 2 
day task, then each resource must work on it for 2 days. If both resources can work at 
the same time, then the total duration of the task will remain unchanged. If however, 

they are working at different times then the duration of the task will likely change. 

 

Example 

A two day task starts on Monday and finishes on Tuesday. Two resources are then 

allocated to it. 

Resource 1, works both Monday and Tuesday, thus finishing its contribution within the 2 
day duration. Resource 2 however is on holiday on Monday, and therefore starts its 2 day 

contribution on Tuesday, finishing Wednesday. 

Therefore the task starts on Monday with resource 1 and finishes on Wednesday with 
resource 2; thus having a new duration of 3 days. 
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Modifying allocations 

When modifying a resource allocation, it is necessary to understand that you are 
changing one of three variables, units of resource, the other two being task duration and 

work. 

When you change the units of resource, either the duration of the task will change, or the 
amount of work will change, as the three variables can the represented in the formula 

 

Duration x Units of Resource = Work 

 

So, increasing the units of resource would require either the duration to decrease and 

work to remain fixed; or for Work to increase and duration to remain fixed.  

The key is to be able to specify which option applies. 

 

Procedure 

1. Open the Gantt chart 

2. Split the screen to show the details pane 

3. Select the task to be modified. 

4. In the lower pane ensure the “Effort Driven” tick box is empty. If there is a tick in 

the box remove it then click OK before proceeding (see below) 

5. If you want the duration to alter change the task type to “fixed work” 

6. If you want work to alter change the task type to “fixed duration” 

7. Add or remove resources as required 

8. Click OK 
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Effort Driven Scheduling 

Assigning Additional Resources to a Task 

When you assign resources to a task, Project shortens the task duration and when you 
remove resources from a task, Project lengthens the task duration. This is called effort-

driven scheduling. It does not, however, change the total work for the task. 

Effort Driven Scheduling is switched on by default in versions up to and including MS 
Project 2007. 

If a task has the effort driven property selected, project will assume that any increase in 

the initial resource allocation will cause a proportionate decrease in the duration of the 
task. 

For example, if painting the walls of a room takes 1 day with one person, adding an 

initial resource will reduce that time to half a day. 

There are two issues here: 

1. Some task durations do not respond to extra resources. It is unlikely that a meeting 
will go more quickly if more people get involved! 

2. Even if a task’s duration does respond to extra resources, it is unlikely to be a simple 
linear relationship. To take an extreme example, if it takes 1 person 1 day to paint a 
100 square meter room, then according to effort driven scheduling, 100 people could 

do it in 38 minutes. This is clearly unrealistic as 100 people would be unable to fit into 
a room of that size! 

It is often easier to disable effort driven scheduling, and control the process for yourself 
using the above method. To switch effort driven scheduling off for new tasks do the 

following: - 

Click on Tools > Options and select the Schedule tab 

1. Remove the tick in "new tasks are effort driven" 

2. Click "Set as default" 
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Task Types 

You can control the way your task schedule is managed by selecting task types. By using 
task types, you can make one of the following three variables—duration, work, or units— 
unchangeable in scheduling calculations. Setting any of the three task variables as fixed 

provides an extra measure of control over the project schedule. Since the duration of 
each task is determined by the formula Duration = Work / Units, you can choose that 
part of the equation that Project calculates by setting the Task type. 

You can set any of the three task variables as fixed using the Task type drop-down list. 

Fixed Units A task with a fixed unit value. This is the default Task type. 
Assigning additional resources to a task reduces the task’s duration. 
For example, if one resource is assigned to complete the task of 

stuffing envelopes, adding another resource will shorten this task’s 
duration. 

Fixed Duration A task with a fixed value of duration. Any changes made to the 
work or to the assigned resources does not impact the task’s 

duration. Assigning additional resources to this task type decreases 
the individual unit values for resources. For example, if a delivery is 
made from one site to another and only one truck is necessary to 
complete the task, assigning additional resources to the task does 

not decrease the task’s duration. 

 

Fixed Work A task in which the amount of work to be completed is fixed. If 

changes are made to the task’s duration or to the number of 
assigned resources, there is no impact on work. Assigning 
additional resources shortens the duration of the task for this task 
type. If a task has a task type of Fixed Work, you cannot change 

the Effort driven setting for that task. 
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Finalising the Plan 

Reviewing the schedule 

 

Once your project plan has been set up with linked tasks, resources have been created 
and assigned to the relevant tasks and task relationships have been set up... you will 
now be ready to set the Baseline and begin tracking the project progress. 

 

Before setting the Baseline it would be good to review your schedule and examine certain 
areas of your plan to make sure that everything is in place to ensure a successful 
outcome for your project. The following areas need to be reviewed before proceeding 

with setting your Baseline: - 

 

1. Check that your calendar settings are correct (all exceptions entered). 

2. Check that the correct calendar has been assigned to the project. 

3. Ensure that all resource calendars have been updated (annual leave etc.). 

4. Check that all 'Summary Tasks' have been inserted correctly. 

5. Check that all 'Milestone Tasks' have been inserted into your project. 

6. Check all durations. 

7. Check that all tasks have assignments. 

8. Check that the predecessor and successor links in the project are correct. 

9. If there are any tasks that can be done simultaneously (Start-to-start / Finish-to-

finish) edit these in the Predecessors column of the Task Entry table. 

10. Tasks that should be 'Effort Driven' must be activated to allow for this procedure 
(Edit the Task Type in the 'Advanced' tab of the Task Information dialogue box). 

11. Fixed Duration tasks should be activated to allow for this procedure (Edit the Task 

Type in the 'Advanced' tab of the Task Information dialogue box). 

12. Check for any over allocated resources and adjust the schedule accordingly. 

13. Check that all Recurring Tasks such as meetings etc. have been inserted. 

14. Check that all required constraints have been set. 

 

You are now ready for the next step of setting your Baseline and then on to tracking the 
progress of your project. 
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Leveling Resource over-allocation 

Resource leveling is the process that ensures resource demand does not exceed resource 

availability. 

There are two stages to this process; first identify specific over allocations, and then fix 
them. 

Identifying over allocations 

Go to the Gantt chart. Turn on the Resource Management toolbar: View > Toolbars > 
Resource Management 

 

Click the Resource allocation icon (first icon from the left) on the Resource Management 
toolbar 

Any resources which are over allocated will appear in red in the top half of the split view 

To identify over allocations click on the “Go to next over allocation” button (third icon on 
the bar) 

Fixing over allocations 

There are 6 general approaches to solving over allocations 
1. Increase the resource’s working time for the period in question 

2. Swop the resource for another resource 

3. Delay the task until the resource has availability 

4. Temporarily suspend work on a task (splitting) 

5. Contouring resource allocation 

6. Changing the logic of the program 

Increasing the working time 

1. Go to the Resource sheet 

2. Double click on the resource 

3. On the general tab alter the resource’s availability by: 

a. First, specify a start and end date and then, 

b. Change the percentage availability to a point where they can cover all the 

available work. 
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For example, if a resource normally works 8 hours in a day, increasing their availability to 
150% would mean that on the days specified they are available for 12 hours. 
 

Swopping the resource 

Select the relevant task in the Gantt chart 

 

Click on the “Assign Resources” button on the toolbar 

 

1. Select the resource to be replaced 

2. Click replace 

3. Select the new resource 

4. Click OK 

Delaying the task 

This involves using the levelling delay field. A levelling delay is a delay specifically 

associated with resourcing issues. We are saying that while the task can physically start 
at time X, we are delaying it to time Y as only then do we have the necessary resources 
available. The key point is it is easily identified and, in the event more resources become 
available, removed. 

1. Go to the Gantt chart view 

2. Add in the “Levelling Delay” column  

3. Select the task to be delayed 

4. Specify the duration of the delay in the levelling delay field 
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Splitting tasks 

This allows you to start work on a task, and then suspend work for a period of time while 
the resource works on another task. To split a task: 

1. Click on the Split Task button on the standard tool bar 

2. Then position the mouse pointer on the task where the split should start 

3. Click once to place a single day split (default) or click and drag to the right, along 

to the point where the split is to finish 

 

Task bar after being 

split

Split button

 



www.microsofttraining.net Tel: 0207 987 3777 Page 23 
© Best Training 2013 

Resource contouring 

It is possible to specify the number of hours per day that a resource works on a task.  

For example; a resource works an 8 hour day. It is allocated to two concurrent tasks and 

will initially be set to work 8 hours on the first task, and 8 hours on the second; thus 
working 16 hours in an 8 hour day. It may be however that the resource need only work 
4 hours per day on task 1 and 4 hours per day on task 2, thus resolving the over-
allocation. This is known as resource contouring. 

1. To contour a resource allocation, switch to the Resource Usage view by choosing it 

from the View Bar or 

2. From the view menu choose Resource Usage 

3. Then manually enter the daily hours worked alongside each resource's 

assignment. 

 

 

Changing Project logic 

Sometimes it is not possible to resolve over-allocation using the above methods. Under 
these circumstances it may be necessary to re-examine; 

Task Dependencies 

Task Constraints 

 

In addition, if the project is to be completed on schedule, the only solution may be to 
bring in additional resources. 
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Tracking progress 

Project tracking involves measuring actual progress and performance and comparing that 
with the planned schedule 

Saving/Setting the baseline 

Once a project plan has been completed and its resources assigned, it is necessary to 
save/set a baseline. A Baseline is a snapshot of the project, and is used to compare what 
is planned to happen with what actually does happen. The baseline is very important, in 
that it is fundamental to analysing cost and schedule variances. If you are connecting 

several plans to a resource pool, save/set the baseline on each individual plan. You will 
be able to see the combined baselines in the master project. 

To save/set the baseline: 

1. Click on Tools > Tracking > Save/Set Baseline 

 

2. Select “Save/Set Baseline” and “Entire Project” option buttons > Click OK 

Note: On the Tracking Gantt view, each task bar is split horizontally in 

two. The lower gray part represents the baseline, whilst the upper coloured 

bar represents actual progress. 
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Entering project progress 

Tracking actual durations involves marking off tasks to indicate how much of the 

scheduled task has been completed.  

One method is to use the pre-set progress buttons. Activate the tracking toolbar by 
clicking on View > Toolbars > Tracking 

 

Elementary progress can be marked off using the 25%, 50%, 75% and 100% buttons. 

More detail can be accessed by clicking on the Update Tasks button, which activates the 
dialog box of the same name. 

 Update tasks is found after the 100% progress button on the tracking toolbar 

 

Progress can be marked off in the following ways: 

Percentage Complete Use this to mark off how much of the task’s total 

duration has been completed. 

Actual Duration This can be used to mark off how long a task actually 
took to complete 

Actual Start When a task actually started 

Actual Finish When a task actually finished 

Remaining Duration How much time is actually required to complete a task 
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Progress - Work 

It is also possible to track the amount of work carried out on a task. To do this: 

1. Go to the Resource Usage view 

2. Double click on a task assigned to the resource whose progress you want to 
record 

3. From the dialog box that appears choose Tracking 

 

 

4. Enter the Actual Work completed (in hours) and remaining work still to be done 

 

Viewing Variance information 

The Variance Table 

The Variance table allows you to check if your project is on track. The Start and Finish 
columns display actual dates for tasks that have started and projected dates for those 
that have not, respectively. The Baseline Start and Baseline Finish columns display 

the planned start and finish dates. The Start Var and Finish Var columns show the 
difference between the actual and baseline dates. Negative numbers indicate tasks that 
are ahead of schedule, whereas positive numbers indicate tasks that are behind the 
schedule. 

 

• To view variance information in a sheet view without the Gantt Chart, from the 
View menu, select More Views then select and apply the Task Sheet 

• Then from the View menu, go to Table: and then click Variance. 
 

The Variance table shows start and finish dates for both scheduled information 
and baseline information, making it possible to evaluate your prediction of how 

the project would progress (baseline) by comparing that prediction with how the 
project is in fact progressing (actual). 

• To view variance information visually, click the View menu and select Tracking 
Gantt. 
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The baseline appears on the Gantt chart as a grey bar underneath each of the 
existing bars and the % complete is displayed.  By default the initial baseline data 

is displayed and if you wish to see a different baseline, from the Format tab click 
the Baseline command and choose the Baseline you wish to display: 

 

 

• To view multiple baselines, click the View menu, click More Views and choose 
Multiple Baselines Gantt: 
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Note:  The Multiple Baselines Gantt view shows the first three baselines 

(Baseline, Baseline1, and Baseline2).  
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Filters and Sort 

Working with auto filters 

In addition to standard filters Project 2003/07 provides AutoFilters, visible in any sheet 
view where each column in a sheet view has its own AutoFilter indicated by the drop 

down arrow on each of the column headings: 

 

 

The Project menu provides access to tools that help Project Managers focus on key tasks 
by applying filters and sorting of tasks and resources. 

From Project > Filtered For: choose AutoFilter. The same menu gives access to 
sorting. 

 

 

The triangular buttons at the top of each column in the sheet can now be used to apply 
filters by column. 
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Applying built-in filters 

A filter is used to screen out unwanted tasks for a particular view to identify a particular 

aspect of the current state of the project, for example the filter can be set to show the 
tasks that make up the Critical Path. 

 

As with tables there are different filters for tasks and resources and depending on the 
current view the appropriate list of filters will be shown for the selection. 

 

1. Select the view you want to filter (eg Gantt Chart, Resource Sheet, etc) 

2. From the Project menu go to Filtered for: All Tasks 

3. Choose the required Filter from the list 

4. These actions can also be carried on the Formatting toolbar 

5. Remove the filter by choosing All Tasks  
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Adding new columns 

It often happens that you may wish to view additional data in a table and to do this you 

need to insert a new column using a specific Project field.Each table in Project has a set 
number of columns, the headings of which are known as field names. Column headings 
may be different to the actual field name if a title has been given.  

 
It is useful to know what fields are available before adding a new column. To add a new 
column to a table, click the Insert menu and then click Column... 
 

 
 
This will open the Column Definition dialogue box from which a field can be chosen using 
the top drop-down arrow. Choose other settings then click OK. The new column will 
always be inserted to the left of the selected column. 

 

Remove a column 

To remove a column from a table you will have to hide it. Right-click the necessary 

column and click Hide column. If you require to bring the same column back you must 
re-insert it as there is no unhide column facility. 
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Analyse and adjust a schedule 

Analysing schedules 

Review schedule differences 

As you track progress through your project, you can review the differences between 

planned, scheduled, and actual work. This helps you assess whether work on your project 
is progressing as expected. You can compare work amounts for tasks as a whole, or for 
resources and their individual assignments.  

The easiest way to compare work amounts with your original plan is to apply the Work 

table to a sheet view, such as the Gantt Chart view or Resource Usage view. The 

value in the Work field represents the current scheduled work value, showing the total of 

actual and remaining work for tasks that have started, and showing the latest projected 

work value for tasks that have not yet started. 

If you saved a baseline, then your original planned work amounts are stored in the 

Baseline field. With this field, you can compare work amounts in your original plan to 

currently scheduled work amounts. The Variance field shows the calculated 

variancebetween planned and scheduled work, that is, the difference between the 

Baseline and Work fields. 

You can also review actual work amounts in the Actual fields. For completed tasks, the 

Work and Actual fields contain the same value. 

Compare Baseline and Scheduled Information 

You can compare baseline and scheduled information in either of two ways: 
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To view variance information in a sheet view, click the View menu move down to 

Tables, and then click Variance. 

 

 

To view variance information graphically, click the View menu then click Tracking Gantt. 

The Variance table shows start and finish dates for both scheduled information and 

baseline information, making it possible to evaluate your prediction of how the project 

would progress (baseline) by comparing that prediction with how the project is in fact 

progressing (actual). 

If the variance in your project doesn't show the values that you expect, there are several 

possible explanations: 

• You might not have set a baseline. The variance is the baseline value compared 
with the actual value for a field. If there is no baseline, Project calculates this 
difference by using a 0 value for the baseline fields, resulting in variances that are 

as large as the scheduled field itself. For example, suppose that you have a 
scheduled cost of £60 for a task. If no baseline is set, the baseline cost is $0. The 
Cost Variance field therefore shows £60. 

 

• You might have set multiple baselines, but Project uses only the initial baseline 
values (that is, the values for the Baseline field, and not the values for 
Baseline1 through Baseline10) when calculating variance. In this case, you 
might see information in variance fields, but the information might seem to be 

outdated and possibly too large. 
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• You might have added new tasks to a project but not added them to the baseline 
plan. In this case, you might see variances that are equal to the scheduled values. 

 

• You might not have updated actual values for those tasks that are completed or in 

progress. In this case, variances might be equal to the scheduled values, or 
otherwise larger than you expect. 

 

• You might have added new tasks or assigned resources and then set a baseline 
plan, but the baseline information for the summary task has not yet been 
updated. In this case, accurate variance values are showing for the individual 
tasks but not for summary tasks. 

 

Identify tasks that are behind schedule 

If you have set a baseline for your project, you can see how tasks progress over time 

and see whether their start and finish dates are slipping. You can track progress by 

comparing baseline and scheduled or actual start and finish dates. 

1. On the View menu click Tracking Gantt. 

2. In the View menu go to Tables then select Variance. 

The Tracking Gantt view displays two task bars, one on top of the other, for each task. 

The lower bar shows baseline start and finish dates, and the upper bar shows scheduled 

start and finish dates so that you can see the difference between your plan and the 

current schedule. 
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Find slack in my schedule 

The amount of slack in your schedule tells you how much you can delay tasks before 

other tasks or the project end date is affected. 

1. On the View menu, select More Views. 

2. The More Views dialog appears. In the Views list, click Detail Gantt, and then click 

Apply. 

 

Slack - 3 days

 

3. On the View menu, go to Tables, and then click Schedule. 

 

In the chart portion of the view, slack appears as thin bars to the right of tasks, with 

slack values adjoining the regular Gantt bars. 

Press TAB to move to the Free Slack and Total Slack fields if they are not visible in the 

sheet portion of the view. 

Notes: If you know where slack exists in your schedule, you can move 

tasks when certain phases of the schedule have no slack and other phases 
have too much. 

Slack values may also indicate a schedule inconsistency. For example, a 
negative slack value occurs when one task has a finish-to-start dependency 

with a successor task, but the successor task has a Must Start On 
constraint that is earlier than the end of the first task. Negative slack can 

also occur when a task is scheduled to finish after its deadline date. 

Reschedule the project 

Reschedule a Task within a project 

You have split a task in your project plan. However, when work is interrupted, you may 
want to specify the date on which uncompleted work should resume. In this topic, you 

will reschedule a task to resume on a specified date. 

 

Situations may arise wherein an employee is unable to complete work on a task as 
scheduled, due to a higher-priority assignment or for personal reasons. In such cases, 

other resources may be unavailable to complete the work, or you may wish to retain the 
same employee on the task in light of her qualifications, skill level, or familiarity with the 
task. Project helps you handle such unavoidable delays by rescheduling the task to 
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resume on a date of your specification with the same employee. This avoids rushing the 
task to completion, requiring unreasonable work hours, and assigning unqualified 
resources to meet the deadline. 

 

How to Reschedule a Task 

1. In the Gantt Chart view, select the task that is to be rescheduled. 

2. If necessary, on the Tracking toolbar, click the appropriate % Complete button, so 

that a progress bar indicating partial completion is drawn in the selected task’s task 
bar. 

3. If necessary, on the Standard toolbar, click the Scroll to Task button to display the 
selected task’s task bar in the Gantt chart. 

4. Choose Tools ���� Tracking � Update Project to display the Update Project dialog 

box. 

5. Select Reschedule uncompleted work to start after and specify the appropriate 

date on which uncompleted work should resume. 

• In the Reschedule uncompleted work to start after text box, type the 
appropriate date. 

• Or, from the Reschedule uncompleted work to start after drop-down list, 
select the appropriate date. 

6. Select 'Selected tasks' and click OK to reschedule the selected task. 

Adjustment of resource schedules 

Shorten the Project Duration 

With the critical tasks identified, you now know the tasks that you have to work with to 
shorten the total project duration. You need to identify the various techniques for 
modifying the project end date. In this topic, you will shorten the project duration. 

 

Knowing how to shorten the total project duration is key to being a successful project 
manager. As project manager, you will have to make decisions that may include 
assigning additional resources to tasks on the critical path, dividing tasks, or removing 

project requirements to shorten the total project duration. 

 

Slack 

Slack is the amount of time that a task can slip before it affects another task or the 
project’s finish date. Free Slack is the amount of time a task can slip before it delays 
another task. Total Slack is the amount of time a task can slip before it delays the 
project finish date. If Total Slack is a negative number, it indicates the amount of time 

that must be saved so that the project finish date is not extended. Slack is displayed by 
the Detail Gantt view and is represented by thin green bars that extend from a Gantt 
bar for a task. 
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How to Shorten the Project Duration 

Assign Additional Resources to a Task on the Critical Path 

1. Use the Gantt Chart Wizard to display the critical path in the Gantt Chart view. 

2. Select a critical task that you wish to add additional resources to. 

3. On the Standard toolbar, click the Assign Resources button. 

4. In the Assign Resources dialog box, select the resources to be added to the critical 
task. 

5. Click Assign and then click Close to assign the additional resource. 

Divide Tasks 

1. From the Task Name, select a task to be divided into two tasks. 

2. Select the text of the task and type the desired task name and press the Enter key. 

3. In the Duration column, type the desired duration and press the Enter key. 

4. Insert a task row above the divided task to add another task. 

5. Type the task name and duration for this newly created task. 

6. If necessary, assign another resource to the divided task. 

Removing a Task 

To remove a task from the project plan, select the row indicator for the task to be 
deleted and press Delete to remove the task. 

 

Identify Slack in the Project Plan 

1. From the menu, choose View ���� More Views. 

2. In the More Views dialog box, select Detail Gantt and click Apply. 

3. From the menu, choose View ���� Table: Schedule ���� Schedule 

4. In the Gantt Chart, slack appears as thin green bars to the right of the tasks, with 

slack values adjoining the Gantt bars. 

5. If necessary, on the Standard toolbar, click the Scroll to Task button to view the 
Gantt bar for the task. 



www.microsofttraining.net Tel: 0207 987 3777 Page 38 
© Best Training 2013 

Progress lines 

 

A Progress line is a visual representation of the progress of your project. For a given 
progress date, Microsoft Project draws a progress line connecting in-progress tasks, 
thereby creating a graph on the Gantt Chart with peaks pointing to the left for work that 

is behind schedule and peaks pointing to the right for work that is ahead of schedule. The 
distance of a peak from the vertical line indicates the degree to which the task is ahead 
of or behind schedule at the progress date. 

 

To view Progress Lines 

1. Right click the Gantt Chart and choose Progress Lines from the shortcut menu: 

2. Click the Dates and Intervals tab and select the required Display options: 

• To always display the current progress line, select the Always display current 

progress line check box, and then click At project status date or At current date to 
indicate where you want the progress line drawn.  

• To display a progress line at specific time intervals, select the Display progress 

lines at recurring intervals check box, click Daily, Weekly, or Monthly to specify a 
time interval, and then click the options you want.  

• To begin progress lines at the beginning of the project, under Begin at, click 

Project start; otherwise, click the date option and then type or select the date on 
which you want the progress lines to start.  

• To display a progress line on a specific date, select the Display selected progress 

lines check box, and then type or select the dates for which you want progress 
lines displayed. To delete a date for which you have set progress lines, select it, 
and then click Delete. 

To show progress compared with a baseline plan, under Display progress lines in relation 
to, click Baseline plan.  

 

Progress line

Pointing to the left - project in arrears

Pointing to the right - project in advance
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Manage Multiple Projects 

Consolidating and sharing projects 

A consolidated project (also known as a master project) contains one or more inserted projects 

(known as subprojects). The inserted projects can retain links to their source projects so that 

any changes in the consolidated project are also made in the source files. The inserted projects 

may be linked to one another to create dependencies. 

 

You can create a consolidated project by inserting copies of individual projects at any outline 

level into a single project file. With a consolidated project, you can view, print, and change 

information for all the projects you're working with (and even those projects "owned" by 

other project managers) as though they were a single project. 

 

When to use a master project and subprojects 

Creating a master project and subprojects allows you to break down a large project and 

delegate its parts to the appropriate people. In project management terms, assigning 

subprojects in this way gives responsibility to those who do the work and matches authority 

with accountability. In Microsoft Project terms, creating subprojects within a master project 

helps individual project managers gain access and control over their parts of the schedule. 

To determine if you should break up a large project into a master project and subprojects, ask 

the following questions: 

• Is the project very large and detailed? If your project will contain more than a 

few hundred tasks, it may be difficult to navigate and manipulate as one large 
file. Breaking it into subprojects can keep it more manageable because you can 
view each subproject individually. If some parts of the project contain work 

that is broken down into more detail than others, it may make sense to make 
those parts into separate subprojects so that most users will see only a rolled 
up description of the subproject, but interested parties can view it in more 

detail if they choose. A single file will almost always be the faster alternative, 
but the ability to focus on just a part of the project may be worth the trade off.  

• What is the corporate culture? In a decentralised or distributed environment, a 

master project and subprojects give workers greater control over their own 
work than one centralised project file does.  

• Does your company do top-down or bottom-up planning? If lower-level 

managers are responsible for and know which tasks are needed on the project, 
it may make more sense to allow them to plan their work and then consolidate 
their project files in a master project. If top-down planning is the norm, you 

may want to reorganise the initial plan into subprojects when it is implemented 
so that individual project managers or teams have access to and control over 
their own schedules.  

• Are you working on multiple projects? Project managers may have a set of 

projects they work with all the time, whether the projects are interrelated or 
not. Instead of opening them one by one, all the subprojects are opened at 

once when the master project is opened. This approach also makes it easy to 
generate reports on multiple projects quickly. If the projects are interrelated, 
the project manager can create task dependencies between tasks in different 

projects. Creating dependencies between projects makes it easier for different 
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project managers to see how work by other project managers affects their 
schedules.  

• Are some projects subordinate to other projects? You can accurately reflect the 

hierarchy of multiple projects by inserting various projects into other files. The 
resulting structure of subprojects should reflect the priorities and 
responsibilities of your team members as well as the interrelationships between 
tasks in different areas and the overall deadline.  

• Is your project modified by several people? Ideally, one file is owned, 
managed, and modified by one project manager. But often a project is part of 

a larger program that upper-level managers may need to manage. If you have 
such a project, your team can retain focus on their work by viewing it as a 
separate file. And the project manager who controls the master project can 

coordinate each subproject team's schedule. It may even make sense to have 
the master project's milestones drive each subproject team's milestones in 
order to keep the schedules coordinated for a deadline. (Coordinating the 
milestones can be done by creating a dependency between the milestones or 

by copying and pasting the milestone tasks from the master project to each 
subproject.)  

• Are there multiple stakeholders who care about different parts of the project? 

When people want to look at different details, project managers can put all the 
project files on a server and customise different views for various stakeholders. 
The same project file can be used as a subproject in different master projects 
to tailor the information displayed.  

• Do you want the subprojects to be read-only? You can retain additional control 

over parts of a project by moving tasks to a subproject and restricting access 
to key people.  

• Do you want to analyse the critical path for each phase as well as the overall 

project? Each individual project contains a critical path. Consolidating multiple 
projects into one master project file makes it easy to see the overall picture as 
multiple critical paths in the master project while retaining separate critical 
paths for each subproject. 

Insert subprojects into a master project 

1. Open the project that you want to become a master project – or create a new project. 

2. In the Task Name field, click the row below where you want to insert the project.  

3. From the Insert menu click Project 

4. Navigate to the drive/folder of the required project  

5. Select the project and click Insert.  

Tips  

• To insert multiple projects, hold down CTRL and click the projects in the order that you 

want to insert them.  

• By default the sub project is linked – meaning any changes you make in the master file 

will also be made in the individual project – you can uncheck the Link to project option. 

• To insert a project in read-only format, click the arrow on the Insert button, and then click 

Insert Read-Only. 

• After you've inserted a subproject, you can show a subproject's hidden subtasks by 

clicking the subtask's outline symbol, the plus sign that appears before the subproject's 

name 
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• When consolidating projects into a master project, resources remain in the individual 

projects. You cannot assign a resource from one subproject to another subproject. 

 

Resources pools - sharing resources across projects 

It is very often the case that an organisation will be running multiple projects 
simultaneously and that as a consequence resources will be shared across those projects. 
It is therefore necessary to be able to allocate resources across different projects and to 
resolve resourcing issues as they arise. 

To do this it is necessary to create a shared resource pool and then set each project to 
get its resources from the shared pool.  

Creating a resource pool 

Create a new blank project and list all the organisation’s resources in the resource sheet. 
As this will be the resource pool for all the organisation’s future projects it is worth being 
thorough and including as much detail as possible. Then save the file in an easily 
accessible location with a suitable name, e.g. “Resource Pool”. Existing resources can be 

copied from existing projects. 

Linking projects to the resource pool 

1. Open the resource pool plan 

2. Open the project that you wish to link to the resource pool 

3. Click on Tools > Resource Sharing > Share Resources 

 

4. From the dialog box that opens select “Use Resources” and choose the resource 

pool file in the “From” drop-down, then click OK >Save both files 

5. Repeat this for each project file that will be connected to the resource pool. 
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Working with the master project 

1. Open the resource pool 

2. In the dialog box select the third option which prompts you to create a master 

file. 

Project will then create a master file, which shows all the projects in one Gantt chart. You 
can then allocate and level resources in the normal way, across individual projects. 

 



www.microsofttraining.net Tel: 0207 987 3777 Page 43 
© Best Training 2013 

  

Exchange project data 

Export to Microsoft Excel 

Introduction 

Having created the project plan file in the Project Initiation and Project Planning phases, 

the file now becomes your plan’s focal point, with essentially three “masters” to serve—
the project manager (you), stakeholders (clients and management), and team members 
(resources). Each master will often have different requirements from the plan. In this 
lesson, you will learn how Project can help you meet these often wide-ranging 

requirements. 

 

Each project involves the combined efforts of various team members. This frequently 

requires working with data in different formats to build the project plan and exchanging 
project information among team members. Fortunately, Project can exchange data with 
various file formats, thus saving time and avoiding the risk of committing mistakes that 
could occur while typing. 

Export Project Plan Data into Excel 

You want to share information in the project plan with your colleagues in a more user-
friendly format. In this topic, you will export project plan information into an Excel 

workbook. 

 

You have created an internal plan and wish to send this information to all your team 

mates. Since most of your team mates do not have Project installed, you decide to send 
the plan in a different format. Rather than recreating the data in Project, exporting the 
required information to the other applications will minimize your effort and save time. 

The Export Wizard 

Exporting is a method of transferring a copy of data from the application in use into a 
different application. The Save As dialog box, enables you to export project information 
with the help of the Export Wizard. Project can export all the data or selected data from 

the plan and save it in different file formats such as Excel files, Excel Pivot Tables, text 
files, comma-delimited text files, or XML files. 

 

The Export Wizard allows you to pick the type of data to export—task, resource, or 

assignment. It reads the Project file and helps you map data from the source file into the 
destination file. Similar to importing data, once data is exported from a source file project 
plan to a new destination file format, no connection remains between the two files. 

Maps 

Definition: 

In Project, a map is a set of instructions that traces the type of data that is to be 

imported or exported, as well as the location where the data is to be imported into a 
project plan. It enables the user to specify which fields in the source file should 
correspond to fields in the destination file. Maps are of two types, import maps and 
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export maps, which in turn may be custom or predefined. 

 

How to Export Project Plan Cost Data into Excel Using Existing Maps 

1. With the desired project plan open, choose File ����Save As. 

2. In the Save As dialog box, from the Save as type drop-down list, select Excel 
Workbook (*.xls) 

 

3. Click Save. 

4. On the Export Wizard, click 'Next'. 

5. On the Export Wizard - Data page, select the format of the data you wish to export. 

• Select Project Excel Template to export the data completely into the Excel 
workbook. 

• Select Selected Data to export only the data you select into the Excel workbook 
and click Next. 

a. On the Export Wizard - Map page, select Use existing map. 

b. On the Export Wizard - Map Selection page, from the Choose a map for 
your data list box, choose Cost Data by Task map and click 'Next'. 

c. On the Export Wizard - Map Options page, select the type of data— Task, 
Resource, or Assignments—you want to export, and click Next. 

d. On the Export Wizard - Data Mapping page, choose the names of the 
database fields you want to export and then map them to the corresponding 

fields that will receive the exported data. 

6. Click Finish to export the data. 

 

Export Project Plan Data to an Excel Workbook Using Custom Maps 

1. Display the Export Wizard. 

2. On the Export Wizard, click 'Next'. 

3. On the Export Wizard - Data page, select Selected Data to export specific 
information and click Next. 

4. On the Export Wizard - Map page, select New map. 

5. On the Export Wizard - Map Options page, select the type of data to export, and 

click Next. 

6. On the Export Wizard - Data Mapping page, map the fields as desired. 

7. If necessary, click Next and save the map. 

8. Click Finish to export the selected file using the custom export map created. 
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Importing data from Microsoft Excel 

 

Project can interact with other applications. This capability allows you to incorporate data 
into the project plan from files in different formats. In this topic, you will import project 
information from other applications. 

 

Assume that you need to include task information in Project using data from an Excel 
worksheet. Rather than retyping the data and risking typographical errors, you can 
dynamically transfer the Excel worksheet containing the desired data to Project. By doing 

this, you not only avoid data entry mistakes but also save time. Furthermore, Project 
allows you to choose the content that is to be inserted into the plan, thereby preventing 
the potential problem of accidentally deleting some necessary data along with 

unnecessary data. 

Import Formats 

Importing is a method of fetching data from a source file in a particular application to a 

destination file in a different application. Project can import all the data or selected data 
from a file. 

 

It can import task, resource, or assignment data into new or existing project plans. The 

imported data can be manipulated in the project plan without affecting the source file. 
Project can import file formats, such as Excel workbooks, Access databases, comma-
delimited files, text files, XML files, and Outlook tasks. The Import Wizard is triggered 
for all file formats except Project files and Outlook tasks. 

 

Note: Project now supports the XLSX file format for Excel workbooks. 

Hence, workbooks saved in this format can now be imported into Project. 

 

Import Outlook Tasks 

Project can also import task information from Microsoft Office Outlook. To do so, from the 
Tools menu, choose Import Outlook Tasks and in the Import Outlook Tasks dialog 
box, select the tasks you wish to import. However, the user must possess an Outlook 

account to use this option. 

 

The Import Wizard 

In Project, the Open dialog box enables you to import files into the project plan. When a 
file format other than a Project file is opened, the Import Wizard is displayed. The 
Import Wizard helps you map data, if mapping is required. Mapping is not required for 

XML files and files created with Microsoft Project import templates. This wizard can 
import selected data or an entire file into a new project plan, or as an addendum to an 
existing, open project plan. 
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How to Import Project Information 

Import a File Based on the Project Import Template into a New Project Plan 

1. Open the project plan into which the Project import template-based file is to be 

imported. 

2. Choose File ���� Open. 

3. In the Open dialog box, from the file type drop-down list, select the format of the file 
you would be importing. 

4. Select the desired Project Import template-based file you wish to import, and click 
Open to display the Import Wizard. 

1. On the Import Wizard, click Next. 

2. On the Import Wizard - Data Type page, select the format of the data you wish to 
import and click Next to import the selected format into the project plan. 

Note: Selecting the Only Selected Data option requires that the user map 

the data to the project plan. 

3. On the Import Wizard - Import Mode page, select the format in which you wish 

to import the data and click Finish to import the file based on a Project Import 
Template into a new project plan. 

Create a Custom Import Map 

1. Display the Open dialog box. 

2. In the Open dialog box, select the file that is to be imported and click Open. 

3. On the Import Wizard, click Next. 

4. If necessary, on the Import Wizard - Map page, select New Map. 

5. Click Next. 

6. On the Import Wizard - Import Mode page, select the format in which you wish to 
import the data and click Next. 

7. On the Import Wizard - Map Options page, check the type of data—Task, Resource, 
or Assignments—you want to import, and click Next. 

8. On the Import Wizard - Data Mapping page, choose the names of the database 
fields you want to import and then map them to the corresponding Microsoft Project 

fields that will receive the imported data. 

9. If necessary, click Next and save the map. 

a. On the Import Wizard - End of Map Definition page, click Save Map. 

b. In the Save Map dialog box, in the Map Name text box, type a name of the 

custom map. 

c. Click Save. 

10. Click Finish to import the selected file using the custom import map created. 
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Project 2007 additional features 

In addition to updating the controls for Calendars the 2007 version of Project includes 
some additional features which you may find useful: 

 

Feature Description 

Multiple undo Makes “what if” testing of the plan much easier. Can be 
adjusted by going to Tools > Options > General and 
changing Undo Levels. If you find Project runs slowly 

reducing the number of steps you can undo may 
improve performance 

Tasks drivers Click the task drivers icon then select a task. The pane 

to the left of the task list displays the elements in the 
plan affecting the selected tasks  

Change 
highlighting 

Project highlights cells that change as a result of the 
most recent edit you make to the plan 

Cell shading   Cells in the table can now have background colours. Go 
to Format > Font or Format > Text Styles to apply 

Enhanced Views Bars now have 3D shading (Tools > Options > View tab) 

Calendar view can now display in week intervals as well 
as by month 

 

Visit www.microsofttraining.net/forum for in-depth answers from Microsoft-qualified 
trainers.  


